网站地图
zenghuilan.com
生活小窍门 解释生活中的一切名词
composer 发布于:

Composer 是 PHP5.3以上 的一个依赖管理工具。它允许你声明项目所依赖的代码库,它会在你的项目中为你安装他们。Composer 不是一个包管理器。是的,它涉及 "packages" 和 "libraries",但它在每个项目的基础上进行管理,在你项目的某个目录中(例如 vendor)进行安装。默认情况下它不会在全局安装任何东西。因此,这仅仅是一个依赖管理。

Composer是PHP中用来管理依赖(dependency)关系的工具。你可以在自己的项目中声明所依赖的外部工具库(libraries),Composer会帮你安装这些依赖的库文件。

安装Composer需要完成以键府杠下两步:第一:下载Composer到你的项目目录。使用以下命令:

$ curl -s (Composer web site)/installer | php

此命令只检查少量的PHP配置,然后下载 composer.phar 文件到你的工作目录,此文件就是Composer执行文件,它是一个PHAR(PHP归档文件,里面可以市境拔包含任何文件,并泪讲估企且可以在PHP命令行执行)。

第二:安装Composer到指定辨遥祖榆目录,即束宙龙在命令行后添加 --install-diroption 参数。使用以下命遥戒户令:

$ curl -s (Composer web site)/installer | php -- --install-dir=bin

假定你在创建一个项目,你的项目中需要一个输出日志主嘱的库,而且你决定使用monolog库。为了将monolog库添加到你的工程,只需创建 composer.json 文件,这个文件中的内容描述了项目的依赖关系。示例如下:{ "require": { "monolog/monolog": "1.2.*" }}

这行简单文字声明了被依赖的库 -- monolog,版本为1.2。


相关文章推荐:
管理工具 | 代码库 | 包管理器 | PHP | 依赖关系 | PHP | 依赖 | monolog | json |